MySQL Workbench 5.2.38 GA Available

The MySQL Developer Tools team is announcing the next maintenance release of it’s flagship product, MySQL Workbench, version 5.2.38.
74 bugs were fixed in this version.

MySQL Workbench 5.2 GA

• Data Modeling
• Query (replaces the old MySQL Query Browser)
• Administration (replaces the old MySQL Administrator)

Please get your copy from our Download site. Sources and binary packages are available for several platforms, including Windows, Mac OS X and Linux.

http://dev.mysql.com/downloads/workbench/

Workbench Documentation can be found here.

http://dev.mysql.com/doc/workbench/en/index.html

In addition to the new Query/SQL Development and Administration modules, version 5.2 features improved stability and performance – especially in Windows, where OpenGL support has been enhanced and the UI was optimized to offer better responsiveness. This release also includes improvements to the scripting capabilities of the SQL Editor. You can read more about it in

http://wb.mysql.com/workbench/doc/

For a detailed list of resolved issues, see the change log.

http://dev.mysql.com/doc/workbench/en/wb-change-history.html

If you need any additional info or help please get in touch with us.
Post in our forums, leave comments on our blog pages or if you want to talk to us directly you can visit us on our IRC channel #workbench on irc.freenode.net.

– The MySQL Workbench Team

4 thoughts on “MySQL Workbench 5.2.38 GA Available”

  1. I was using Workbench 5.2.35 on a Debian 64 Wheezy. It crashed every 2 minutes. But since I’ve updated to GA 5.2.38, it only crashes every 5 minutes. Seriously, I believe I’ve never managed to work 15 minutes in WB without a crash. So I’ve been cursing WB for 2 years now. Some crashes are reproducible, others seem random.
    I don’t know about other environments, but I suggest the linux 64 bits version should be tagged “alpha release”.

    1. Rogojine: If you get reproducible crashes, you should file bug reports with instructions on how to repeat.
      Also, Debian is not supported, if you use our packages there may be some incompatible difference in libraries.

Leave a Reply